NATION

PASSWORD

Password recovery isn't working right.

Bug reports, general help, ideas for improvements, and questions about how things are meant to work.
User avatar
Belle Hades
Civil Servant
 
Posts: 7
Founded: Dec 16, 2004
Ex-Nation

Password recovery isn't working right.

Postby Belle Hades » Fri Jun 26, 2009 5:42 pm

The password for my main nation all of a sudden stopped working, and when I tried password recovery, I did get the email, and when I clicked on the link, i got this:

Image

Here's the message in it's entirety:

<!DOCTYPE html
PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en-US" xml:lang="en-US">
<head>
<title>Oh-oh...</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
</head>
<body>
<h1>Error!</h1><p>Sorry, NationStates has encountered an error. This problem has been logged and will be looked at shortly. If it occurs repeatedly, though, you can help us track it down by telling us what you did to reach this message. Please e-mail <a href="mailto:admin@nationstates.net">admin@nationstates.net</a>, giving this error message, the time and date it occurred, and what you were attempting to do. </p><p>Alternately, you can post this as a bug report in the <a href="http://forum.nationstates.net/viewforum.php?f=15">NationStates Technical Forum</a>. Thanks.</p><h3>Details:
</h3><pre>Can't call method &quot;query&quot; on an undefined value at /home/nation/public_html/cgi-bin/index.cgi line 613.
at /home/nation/public_html/cgi-bin/JGConfig.pm line 13
JGConfig::__ANON__('Can\'t call method &quot;query&quot; on an undefined value at /home/nat...') called at /home/nation/public_html/cgi-bin/index.cgi line 613
ModPerl::ROOT::ModPerl::RegistryBB::home_nation_public_html_cgi_2dbin_index_2ecgi::cookiebomb_check('CGI=HASH(0x7f9366413e10)') called at /home/nation/public_html/cgi-bin/index.cgi line 422
ModPerl::ROOT::ModPerl::RegistryBB::home_nation_public_html_cgi_2dbin_index_2ecgi::post_login('Nation=HASH(0x7f93664131f8)', 'CGI=HASH(0x7f9366413e10)') called at /home/nation/public_html/cgi-bin/index.cgi line 434
ModPerl::ROOT::ModPerl::RegistryBB::home_nation_public_html_cgi_2dbin_index_2ecgi::check_recovery_login('CGI=HASH(0x7f9366413e10)') called at /home/nation/public_html/cgi-bin/index.cgi line 64
ModPerl::ROOT::ModPerl::RegistryBB::home_nation_public_html_cgi_2dbin_index_2ecgi::handler('Apache2::RequestRec=SCALAR(0x7f936a9b4778)') called at /usr/lib/perl5/ModPerl/RegistryCooker.pm line 204
eval {...} called at /usr/lib/perl5/ModPerl/RegistryCooker.pm line 204
ModPerl::RegistryCooker::run('ModPerl::RegistryBB=HASH(0x7f936a9bbfc8)') called at /usr/lib/perl5/ModPerl/RegistryCooker.pm line 170
ModPerl::RegistryCooker::default_handler('ModPerl::RegistryBB=HASH(0x7f936a9bbfc8)') called at /usr/lib/perl5/ModPerl/RegistryBB.pm line 31
ModPerl::RegistryBB::handler('ModPerl::RegistryBB', 'Apache2::RequestRec=SCALAR(0x7f936a9b4778)') called at -e line 0
eval {...} called at -e line 0
</pre>
</body>
</html>


copy and pasting the url gets the same effect.
Last edited by Belle Hades on Sat Jun 27, 2009 10:45 am, edited 1 time in total.

User avatar
Erastide
Retired Moderator
 
Posts: 1299
Founded: Antiquity
Democratic Socialists

Re: Password recovery isn't working right.

Postby Erastide » Sat Jun 27, 2009 2:41 am

o.O Airline Mogul? Are you sure you did that right?

User avatar
Belle Hades
Civil Servant
 
Posts: 7
Founded: Dec 16, 2004
Ex-Nation

Re: Password recovery isn't working right.

Postby Belle Hades » Sat Jun 27, 2009 10:45 am

Erastide wrote:o.O Airline Mogul? Are you sure you did that right?

Fixed.

User avatar
Erastide
Retired Moderator
 
Posts: 1299
Founded: Antiquity
Democratic Socialists

Re: Password recovery isn't working right.

Postby Erastide » Sat Jun 27, 2009 2:00 pm

So you're still getting this then? Pyth fixed some things earlier. He or [violet] will have to fix this problem if it's still happening. Also, did you try the process again?

User avatar
Pythagosaurus
Cute Purple Dinosaur
 
Posts: 549
Founded: Nov 24, 2004
Civil Rights Lovefest

Re: Password recovery isn't working right.

Postby Pythagosaurus » Sat Jun 27, 2009 2:22 pm

Fixed.

User avatar
The Plutonian Empire
Diplomat
 
Posts: 935
Founded: Nov 15, 2004
Libertarian Police State

Re: Password recovery isn't working right.

Postby The Plutonian Empire » Sat Jun 27, 2009 2:48 pm

It works now, thank you!
Pro: Nukes, Imperialism, LGBT+ Rights, Welfare, Universal Basic Income, Universal Healthcare, Womens' Rights, Equal Pay, Space & Science prioritizaiton, Privacy, Net Neutrality, Abortion, Environmentalism, Free Love Freedom.
Neutral: Religion.
Against: Capitalism, Fascism, Surveillance, Police Militarization, Misogyny, Thought Policing.

RIP: Grandma Pat, 1934 - 2009
Celestia 1.6.1., Space Engine 0.980, Lavender Skies
Political Compass as of: Dec. 23, 2018
Economic Left/Right: -7.50
Social Libertarian/Authoritarian: -7.69


Return to Technical

Who is online

Users browsing this forum: No registered users

Advertisement

Remove ads